What You Need to Know About Heartbleed

heartbleedHeartbleed is a serious vulnerability in the OpenSSL library.  OpenSSL is considered to be the standard in implementing TLS and SSL cryptography,  and is used by the majority of servers and internet devices.

By now nearly every major player on the internet has updated their software or has provided a fix for the devices they support.  Some of our partners such as Fortinet, Barracuda, and VMware for example all have updates that need to be installed for some of their products.

If you have concerns about the Heartbleed vulnerability contact us and we will work with you to determine if anything on your network is vulnerable and we can assist you in resolving the issue.  Contact us by email or give us a call at: (262) 402-6105 (ask for Carol).